Help - Search - Members - Calendar
Full Version: Problem with mod > Mods > Oblivion Mods
Avatus Darius

I am Avatus Darius. I was referred to this forum following a search for the user, Timeslip. I am trying to get in contact with this member as I have been a user of the mod OBMM (Oblivion Mod Manager) and have come across a problem I am trying to get help with. In short, the error has crippled the use of my game.

I posted the following on the TES Nexus forums, where I originally dowloaded the content. Have not seen a response. I also tried the weblink and found nowhere I could try to communicate and seek help with my issue. Logically, I am trying here as well. My message is as follows:

I had an unusual occurance recently, and was wondering if I could get help with fixing the problem.

I've used OBMM for some time without any problems. However, today I tried deleting the Kvatch Aftermath mod, and got all kinds of buggy happenings. I can't close OBMM without using Windows task manager to do so, nor can I launch Oblivion, or use any of the utilities. OBMM gives the following message in the obmm_crashdump.txt:

Tuesday, May 12, 2009 - 3:11:37 AM
1.1.12 (Safe mode)
OS version: Microsoft Windows NT 6.0.6001 Service Pack 1

Type: System.IO.IOException
Error message: Access to the path 'kvatchaftermath' is denied.
Stack trace: at System.IO.Directory.DeleteHelper(String fullPath, String userPath, Boolean recursive)
at System.IO.Directory.Delete(String fullPath, String userPath, Boolean recursive)
at System.IO.DirectoryInfo.Delete()
at OblivionModManager.MainForm.TidyDataFolder()
at OblivionModManager.MainForm.MainForm_FormClosing(Object sender, FormClosingEventArgs e)
at System.Windows.Forms.Form.OnFormClosing(FormClosingEventArgs e)
at System.Windows.Forms.Form.WmClose(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

I tried uninstalling OBMM, running CC cleaner, and subsequently reinstalling OBMM. This is not working to date. I get the same error situation.

Any ideas? Kind of stuck without my game working...

On any of the forums, including this one that I have found, there is no way to PM this user. Logically, I am trying here. I hope I don't offend anyone, I am simply attempting to seek help in repairing my game.

If anyone else here can make sense of this, and help, all the better...


Avatus Darius
Hey there,

I've moved your question out of the introduction thread and put it in our mod section, I hope you don't mind but I think it would fit better there.

I've also read that you've had little luck in contacting Timeslip directly, I've taken the liberty to send him an email asking him to have a look at your question, I can't promise anything but I hope he'll be able to fix your problem.

Alexander smile.gif
You can pm me on Beth's forums if you need to. I generally try and answer, as long as it's not something covered by the readme or FAQ.

QUOTE(Avatus Darius @ May 12 2009, 01:00 PM) *
OS version: Microsoft Windows NT 6.0.6001 Service Pack 1

...which this issue possibly is. The obvious first thing to check would be to find that folder in explorer and make sure the read only box isn't checked. If it isn't, then FAQ entry 16 probably applies: (specifically, this comes under the heading of random access denied errors.)

16) I'm using windows vista. Why do my mods not show up in game even if they're active in obmm, why are my omods randomly disappearing, why do I get random access denied errors when activating omods, why is obmm generally being really weird?
Short answer: because you're using windows vista. The best solution to all vista related problems is to uninstall it and get a decent operating system. Failing that, disable UAC. (Do a google search if you don't know what UAC is.) If you're only interested in fixing oblivion, either install it somewhere other than the program files directory, (C:\games\oblivion' is the usual choice,) and make sure that all users have write access to that directory, or right click on every exe file in the oblivion folder and its subfolders as well as any other oblivion related tools you keep outside of the oblivion folder, click properties, go to the compatibility tab and check the 'run as administrator' checkbox. (obmm has two additional exe's in the \obmm folder, so be careful not to miss any.)

The long explanation is that all of these problems are caused by a part of vista's security system called user access control, or UAC for short. One of the features of UAC is that all applications are blocked from writing to the program files directory, even if you're logged in to the computer as an administrator. Oblivion requires mods to be installed to its data directory, so if you have UAC turned on and oblivion has been installed to its default location in the program files directory you're obviously going to run into some major problems using mods.

Also fairly obviously, any program written before the release of vista isn't going to know about this new security, so in order to keep backwards compatibility any time a program tries to write to the program files directory windows tells the program that the write has been successful, even though it wasn't. In fact the file being written to is copied to a hidden folder in you user account. (Known as the 'virtual store') Other programs may or may not be able to see these files, depending on your security settings; if oblivion can't see them then you get the problem of mods not showing up in game even though they're active in obmm.

obmm doesn't require admin privileges, but it does need write access to oblivions directory. In versions previous to 1.1.2, it couldn't tell the difference between when it did actually have write access to the oblivion folder, and when windows was just pretending that it did via the virtual store. Since 1.1.2 it can tell the difference, and will start up in limited user mode if its file writes are being redirected.

Also since 1.1.2, if obmm does have full admin privileges, it will offer to move any files which old versions of obmm have left in the virtual store back to the oblivion folder. This will fix any problems with vanished omods, or mods not showing up in game. It's important that you set other mod tools to run as administrator before doing this, or they may start giving access denied errors too. If obmm doesn't have admin privilages, it wont be able to move things out of the virtual store itself, and will just display a warning instead. In this case, you can still move the files out of the virtual store by hand. On a default windows and oblivion install, the folder you need to move is 'C:\Users\[yourname]\AppData\Local\VirtualStore\Program Files\Bethesda softworks\oblivion'. You need to have 'show hidden files and folders' turned on to see the virtual store.

To be fair, vista SP1 is slightly better in this regard, but you still get some random odd permissions issues every now and again.

Incidentally, obmm is somewhat obsolete now; unless you already have piles of omods I suggest you grab a copy of bash/bain instead.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.