Help - Search - Members - Calendar
Full Version: The Fallout G.e.c.k. Topic > Forums > Fallout Games Discussion
I thought about putting this in TK's mod questions topic, but since it is about modding Fallout3, I thought it might be better to create a dedicated Fallout geck questions thread.

I recently came across a few lessons learned that might spare other people some heartburn and wasted hours.

The first is that when creating dialogue in Fallout 3, you must have a mic or headphones plugged into your computers mic jack. Otherwise the Geck will crash when you try to add the dialogue. I think it might only be if you have a Realtek sound card. Since they are common cards, especially in the case of integrated audio cards, it is a good thing to remember.

The second is an issue I found when creating new monsters in FO3. Sometimes new creatures will behave cowardly no matter what you set their AI Settings to. They simply run away from the player character, and will never attack, even if you manage to corner it and get right up in its face. I tracked it down to the mesh and/or texture used by the creature. I finally confirmed it when I changed the cowardly creature's mesh and texture to that of a vanilla creature. Suddenly it became instantly hostile. I then changed it back to the modded mesh/texture, and it became the cowardly lion once more. Of course the modded and meshes and textures are simply copies of the vanilla ones, with the model only being changed to point to the new texture, and the new texture just being recolored.

How a mesh or texture alters behavior in the game is beyond me. I guess it is a "Feature". I did a little searching online and found other people who have had this problem. I never found a solution. The only workaround I found is to create a new creature, test it, and see if its also cowardly or if it attacks.

But that of course is not the end of it. I had three new Snow Scorpions that were all cowardly (copies of the vanilla radscorpions with a white texture). I made a new version that worked correctly. So I deleted my old cowardly scorpions and made two more copies from my working, hostile, snow scorp. Only one copy remained hostile, the other was cowardly. So I deleted it, and made a new copy. The new copy was hostile. But the first hostile scorpion that I had copied it from was then cowardly. Evidently one was always going to be cowardly. Finally I left the cowardly scorpion in the game, and just decided not to use it. I didn't delete it, because then I am certain one of the remaining two would have then become cowardly.

So the bottom line is to keep creating new copies of the monster until you find one that works. Don't delete the cowardly ones, as it just moves the cowardly behavior to another monster that was previously fine. All of this is caused by a new mesh or texture. Thank you Bethesda.
Man, that jumping behaviour really sounds odd. I also donīt understand how a mesh or texture can affect it but then again Iīm not even a modder wink.gif

On the sound card issue - I had the same thing in working with Oblivion dialogue on my old desktop, so I think you are right about it being a sound card related issue. I just had to keep something plugged into the mic jack; just left it dangling there. It fixed all the issues. (Never had that problem with my laptop).

That is so strange that meshes and textures could affect behavior like that! It must conflict in some way, but how? Really odd!

Thank you so much for this thread, what a great idea! I found a lot of the issues in New Vegas were more similar to Skyrim than Fallout 3; which was really odd. But I do agree that the Fallout game modding needs its own thread; really great idea to start one!

I have had a lot of issues with flickering textures on mod added items and textures in New Vegas.

For years now I have been wrestling with an issue of the colors of everything in Megaton looking darkened and desaturated. Everything looked dim and washed out compared to the rest of the world. I tried modding the weather, climate, etc... and never had any luck. Today I finally figured it out. Here is what I did:

Go to the Menu bar -> World -> Cells

Change World Space from Interiors to Megaton World

Open each cell, and change the ImageSpace to WastelandBaseImageSpace

I use Fellout, so my WastelandBaseImageSpace has been modded with different values than the original, to take out the green tint the vanilla game puts everywhere.

Here is an example of the original (Fellout) Megaton

The new improved version

What is really weird about this is that all the Megaton cells are normally set to use the Default imagespace. This is the same that all the Wilderness cells use. The Wilderness cells have always looked great, and Megaton has always looked all dim and desaturated. Even though both were using the same imagespace before.
Oh good, there is a thread for GECK. I don't really have a question, instead I am going to try to document some troubles I'm having. The person at this forum explains it all perfectly.

So ... with Fallout 3 (or New Vegas) apparently Windows 8 or newer does not like to work with the GECK! It's hella frustrating. My gaming computer is 8.1, and it'll open the GECK just fine, and it'll run certain functions. I can make NPCs for instance, and place them into the Wasteland just fine. But if I want to start messing with quest-making or scripts, the GECK doesn't recognize what I'm doing at all, and it has something to do with some updates Windows 8+ I have accepted over the years. So for anyone else out there having these sort of issues, there seem to be others who have conquered them.

Apparently, I'm supposed to look for some sort of "compatibility mode" and I think I've found it. Edit: Nope, didn't work. I made sure to right-click on the GECK exe file, go into its Compatibility tab, and run the program as Windows 7, as an administrator. Didn't work though. mad.gif

Edit 2: This is caused by a Windows 8 update: kb3000850. Various threads on the 'net talk about getting rid of this update, and I tried this, but it also didn't work. The problem is that if you're like me, and you've been updating your computer over all these years, now you've got a zillion updates to get rid of. And SOME of them seem as though they're hardcoded. They cannot be removed. Lesson learned: no more updates! At least, not on my gaming computer.

Final solution: Here it is. For some reason, every topic and condition gets "shoved over to the left." To correct this, you have to highlight the top left corner of each blank window until this little pointer thing shows up which looks sort of like this:


Now, GRAB this with the left mouse button, and literally DRAG to the right. Everything is still there, it's just hidden.

Phew. I need a drink.
Do we have to get rid of navmesh when duplicating a cell? Anyone know? I seem to remember there's some reason for getting rid of old navmesh, and starting with new.
I don't know. I only figured out navmeshing a few years ago. TBH, I don't think the navmesh carried over in the cases where I copied and pasted an interior cell. I am pretty sure I had to create them all from scratch. But I cannot remember for certain.
Okay thanks. I guess I'll go ahead and try simply duplicating some cell but I won't change its navmesh later on when I'm GECKing again. Maybe it'll be fine just the way it is. I am trying to get an NPC to patrol in a certain area and it wasn't working, but it's probably because I screwed something up with the new NM. We'll see.
You don't need to delete the old navmesh if duplicating the cell. It'll work fine in the "new" cell.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2021 Invision Power Services, Inc.